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1. The Admin Area

The web address for the admin area (Content Management System - CMS) of your site is:

http://www.yourdomain.com/admin/
To add or edit web pages go to 
Content => Pages
And you will see something like this:
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Screenshot 1

At the top - navigation for the admin area of your site.
You may see different links here, depending on your administration access.
Click “Add New Content” to make a new page.
Click “Reorder Pages” to change the order of your pages.
If a page has an arrow next to it [image: image2.bmp], it has sub pages. Click the arrow to expand the section and see the pages in that section. Click the arrow again to collapse the section and just see the top level pages.
If you want to change certain page’s content, click the flag of the language you want to edit.
The default page is the first page you will go to when you type in your web address. In your website – the entrance page is marked as default[image: image3.bmp].

Click [image: image4.bmp] arrows to move a page up or down the list. The pages will display in exactly this order on the website.

Click [image: image5.bmp] to delete the page.

Click “Expand all sections” to see all pages in all the sections on the site.

Click “Collapse all sections” to see only top level pages in the site.
2. Adding new content

Click on the link “Add New Content”
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Screenshot 2

You will see 3 tabs “Main”, “Options” and “Preview”

First, you will automatically be in the Main tab window. This is where all the content for the website should be added.

First you will have to create content in English. Once this is submitted, you will be able to add content in other languages by clicking on the flags.

Follow these steps to add new content.

In Content Type you only need to use content types called Content
Page Title - in the front-end website this will appear above the main text of the page, below the horizontal menu of the site.
Menu Text - this will be the text that appears in the menu (navigation).
Keep it short, in order it looks nice on the horizontal navigation menu in the website.
The title and the menu text should normally be the same. The only time they should differ is if the title is too long to fit neatly in the menu.
If you use a very different menu text and title it is very confusing for the user and is bad usability. 
Choose Parent. 
If the page you are entering is going to be on the top level of navigation then select the default ‘none’. 
If not, select the page from the drop-down listing.
E.g., if your new page is ‘Valle de la Luna’, select ‘The Desert’ as parent. 
Template – use the default template called “info pages” for your pages. Template called “entrance page” is specifically designed for the Entrance page of the site.

Enter your content for the page in the Content editor using the WYSIWYG (what you see is what you get) editor (see below for guidelines).
The page can be previewed by clicking on the Preview tab or Preview button in the “Main” tab, or by viewing in your web browser once the page has been submitted (by clicking “Submit” button). 
Click on the Options tab 

Active checkbox – de-select if you don’t want your page to show on your website.
Show in Menu checkbox – de-select if you don’t want your page to show in the horizontal menu (navigation).
Cachable checkbox – keep selected.

Page Alias – you can leave empty – once submitted, it will be generated automatically by taking the value from “Menu Text” field in Main tab.

Add so called Metadata. 
This is essential (!!!) for all content pages to help Search Engines find your pages and increase ranking in the Internet Search results.
The format for the Metadata is the following:
<meta name="description" content="" />
<meta name="keywords" content="" />

In the 1st line write 2-3 lines description of the content provided in this particular page you are editing the content. For example, we are editing the page describing horses in English, the Meta-description can be the following:
<meta name="description" content="Our horses are perfectly trained, well-fed and kept in an environment-friendly way. Horses are ridden everyday in order to keep their good shape" />

Into Meta-description can also copied the first lines from the page content (if it describes the essence of the content).

In the 2nd line enter comma separated keywords describing the content of this particular page you are editing. Example for page about horses:
<meta name="keywords" content="horse, horses, Atacama desert riding, Atacama horse adventure, creole horses, trained horses, well-fed horses" />

In the English version of the page this Metadata should be in English.
In the German version – in German, and so on.

Remember to add Metadata to EACH page of the website in all languages! It will improve the results of how many people will find your website through search engines (like Google, Yahoo, etc…). Sometimes it is really annoying to write all these metadata, but it is unexpectedly essential when we talk about the better our page’s ratings in the results provided by search engines.

Click the Submit button at any time to save your page or to put the page on the website.
Adding Photo Album(s) to the page 
{cms_module module='album' albums='1,3'} Displays album 1 and 3 on your page.
The numbers are the album id number. To get the id number go to 

Content => Photo Albums, in the 3rd column you will see “IDs”.

Use a comma to seperate more than one album IDs.

Adding 1 photo album

For example, in the content page about Saddles you will find the following tag:

{cms_module module='album' albums='20'}

If you would look at the Content => Photo Albums you will see that the ID=20 is of the album called “Saddles”.
Adding more than 1 photo album

There are already created few photo albums with the views from the desert – like Valle de la Luna (ID=16), Valle de la Muerte (ID=17), Valle Catarpe (ID=15). Let’s say you would like to add all these albums under the content of “The Desert” page – open this page for editing and add this line at the bottom:

{cms_module module='album' albums='16,17,15'}

In the “Pictures” page

If you would look at the content which was to the page “Pictures”, you will see this tag written:

{cms_module module='album' categories='1,2,3'}

In this way we can display multiple categories (each of them contain more than 1 album) on our Picture Galleries page. Important: if you will create a new category in the Content => Photo Albums, note the ID of a new category and make sure that you add this ID (separated by comma from others) to the tag found in “Pictures” page (let’s say new ID=4):

{cms_module module='album' categories='1,2,3,4'}
Note

It is also possible to use this tag without parameters:

{cms_module module='album'}
But in your website it is not useful, because in this case all the albums will be displayed in a messy bunch without categories.
3. Editing a Page

Go to Content => Pages and click on the flag of the page you want to edit. 
You can change any information on the page after it has been submitted. You will notice there is now an Apply button next to the Submit button, click this to apply the changes but remain on the same editor page. This saves time when making many changes.

The submit button will take you back to the page list every time.
Do not change the Page Alias text, as this will stop links from working correctly.
4. Notes on Content

Prepare all the texts in plain-text “.txt” file format. Do not copy-paste text from MS Word document – it will transform terrible text formatting into the website. If you already have text in Word, first save this file as text “.txt” file and then do copy-pasting.
5. Using the Content Editor (WYSIWYG)
Prepare all the texts in plain text file format!!! Use Notepad or any other plain-text editor. Do not use MS Word application, because copying text you prepared from Word to the CMS will bring along a terrible formatting that MS Word has by default.
In case you already have some texts in Word document, first save it as a text file “.txt” to get rid of any formatting, then copy-paste process should free of terrible-formatting. 


Explanation of couple of buttons which you will find on the window of content editor:

[image: image7.png]


 - Bold, Italic and Underline – the same as in MS Word.
[image: image8.png]


 - Numbered or Bulleted list – the same as in MS Word.
[image: image9.bmp] - Add a link to a page within the site www.yourdomain.com 

Select the text or image you want to link.

Click this button [image: image10.bmp] and choose the page you want to link to from the list.

Leave the Generate Taglink box checked. This will create a {cms_selflink} tag. This is an internal CMS tag which automaticly generates a proper link to internal page within the site. More about this tag and how to use it, you can read on the here:

http://www.yourdomain.com/admin/listtags.php?action=showpluginhelp&plugin=cms_selflink 

or in the admin area go to Extensions => Tags and then click on cms_selflink


[image: image11.bmp] - Add a link to another website, image file or a document file which is uploaded on your server.

Once you select the text and click the button this pop-up window will open:
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In Link URL enter the web address of a page you want to link to. Should start with “http://”.

If you want to link to an image or document on your website – click on [image: image13.bmp] icon next to Link URL and select the image or document on your server.
Target – you might want to select “Open in new window (_blank)”. This will open a new browser window, so the visitor will still stay in your website.

Title for the link is optional.

Other tabs of this window (Popup, Events, Advanced) you don’t need.

[image: image14.bmp] - this button removes previously created link

[image: image15.bmp] - Insert an image

Once you click this button, you will see this window: [image: image16.png]Ganaral || Appearance || Advancad |

Preview





Write web address of the image or click on the[image: image17.bmp] icon and choose the image already uploaded on the server.

Image Description – write few words describing this image.

Title is not necessary.

Go to Appearance tab:
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Alignment – choose how you want the image to appear. For example, if you want to position it on the right side of the text, select “Right” from the drop-down list.

Dimensions - if your image size (width and height) are too big for this image being shown in the text as it is (e.g., if image has 600px width, it will be shown almost on the whole width of your content area), you will probably want the image to appear in smaller dimensions. Probably up to 200px of width would look nice (if image is in “landscape” format, i.e., width is longer then height).

In the “Dimensions” row – the first field indicates “width”, and the second – “height”. Keep Constrain proportions box checked, and then you just need to enter 1 value in the dimensions. For example “150” in the first empty field, which will mean that in the webpage this image will be shown resized proportionally to the width 150px.

All other parameters, as well as “Advanced” tab you can forget, unless you would like to play around and see what happens (
6. Processing Images

Reduce Images!!!

Please reduce your images to a reasonable size and size before you upload. If everyone uploads huge images the website will soon become overloaded, moreover, it will take ages for site visitor to load the pages.

There is an image editor in Content => Image Manager (the pencil icon [image: image19.bmp] next to the images). This can reduce and crop images. However if you have lots of images it may be quicker to prepare them beforehand. 

It is recommended not to leave spaces in the image file name (use dashes like “_” or “-“).

IrfanView software for image resizing

If IrfanView is not installed on your computer, download it from http://irfanview.com/ 
To resize bunch of images (called Batch conversion) follow these steps:

· Start the program

· For batch conversion click on the keyboard letter “B”, or go to menu File -> Batch Conversion/Rename
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· At the Work as option choose "Batch conversion"
· Output Format: JPG
· Check Use Advanced Options
· Click Advanced button
· In the Advanced window make configuration as it is shown in the next screenshot:
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· Click OK, and you will be back to the Batch Conversion window

· In "Output directory for result files" write the folder in which you would like resized pictures to be saved.
For example you could write like this:
C:\Temp\rancha_pictures\
· Then on the right top, where there is a possibility to choose folders, open the folder with the pictures you want to be resized. Once your target folder is open, select photos you want to resize and click Add button.
If you would like to resize all pictures from that folder, click Add all
The you can choose another folder and add more pictures if you want.

· Once you have chosen needed pictures, click Start Batch. You will see the progress of pictures being resized.

· Once finished, you will find resized pictures in C:\Temp\rancha_pictures\
If you would like to resize a single picture using Irfanview software, you can do it by going to the menu Image -> Resize/Resample, or simply with a shortcut CTRL+[R]. After you will fill all the parameters and click Ok, do not forget to Save As resized picture under the different name.
Image sizes
Photo Albums = max 600px wide. 

General Site Images = 200px on the longest side.

Thumbnails are automatically created once you upload the images to the website.
7. Uploading Images

Any images to be used on the site need to be uploaded to the server before they can be used on the page. 

This can be done via ”File Manager”, “Image Manager” or ”Photo Albums”. All of these modules can be found in the “Content” menu of admin area.

Using the File or Image Manager you have more control and can organize your images into folders.

Go to Content => File/Image Manager
The File Manager lists the files by name and you can upload up to 10 images at once. 

The Image Manager lists images using a thumbnail and dimensions but not the name. It allows to upload only 1 file at once.
Folder names 
Recommended not to leave spaces in the folder names. Upload photos for the galleries under images and appropriate folder names.
8. Uploading Files

If there will be a necessity to upload non-image file, e.g. MS Word or PDF document, use Content => File Manager in the same way as described for images.

9. Photo Galleries
1. Go to Content > Photo Albums
Pictures are arranged into Categories, which contain Albums. Both are managed through “Photo Albums” module.
2. To add a new album, click on the Add an album link.
Name the album and submit.

3. Select to which category the album should be assigned. 

4. (Optional) Click on the notepad icon [image: image22.bmp] or Edit comment to add some summary text about the collection. This will appear above the album title.
5. Click on the Add pictures link at the bottom of the page to add pictures to the gallery.
Prepare in advance by uploading your pictures via file/image manager to a folder in albums.
Images should be 600px wide on their longest side (the thumbnails are created automatically)

6. Browse to the images you want to upload. Check the check boxes to the left of the images to select them, or click select all (at the bottom). Then click Save (at the bottom right). The images will now appear in the album.

7. Each picture has a possibility to add a short comment by clicking on the notepad icon[image: image23.bmp]. Do not make any additional formatting to this comment. This will appear under the large version of the picture.
In the same window change the Title of the photo if possible, in order to avoid having odd photo titles like “DSC_4549.jpg”.
8. Use the other icons under the images in the album to:
[image: image24.png]


 Change the order of the pictures (arrows)
[image: image25.bmp] Change the picture (large image icon)
[image: image26.bmp] Delete (the bin)

Note: as soon as you create a new album, it will be displayed on the gallery page.
10. Configuration of “Contact Us” Forms

The web-forms (in 4 different languages) which are visible on the website can be administrated by going to Extensions => Form Builder.

Here you will see forms in all languages. Let’s say we want to edit the form in English:
· Click on “Contact Form ENGLISH” link

· In the Main tab you will see the 2nd block with the title Form Fields
· Click the first field “NOTIFICATION OF CONTACT FORM”. Here you can change the “Destination Email Address:” (current it is configured for info@yourdomain.com). To this email the feedback form will be sent. In the Advanced Settings tab of this page you may edit the template of email received by administrator once the feedback form is submitted.

· Get back to Main tab of English contact form

· In other language forms (not English) you will have to translate the names of the fields: “Your Name”, “Your Email”, and “Message”. To do that, just click on the name of the field and you will be brought to the form where you can change the values.

· Now let’s go to the Captcha Settings tab (“Captcha” is the image with letters and digits which the visitor will have to repeat before submitting the feedback – in this way the automatic spamming is avoid).

· For other languages than English in this tab you will have to translate values for Help text for Captcha and Failed text for Captcha
· In Submission Template tab you can edit the text which will appear after the person successfully submitted the feedback (this also should be translated for non-English forms).
11. User and Group permissions  

All users are assigned to a group – the group has permissions ‘set’, which can be adapted at any time.

Some groups have a lot more permissions than others.

The group sets on launch are Admin and Editor. 

· Admin group has the access all areas of CMS.

· Editor group has permission to add/edit pages, files and Photo Albums. Limited access. 

You can add as many groups and as many users as you need.

12. Create a user
· Login to admin
· Go to Users & Groups => Users
· Click “Add New User”
· Type a name for the user, and type password twice
· Fields with a * must be completed, so that’s the first 3 on the screen
· Make sure the ‘active’ checkbox is selected
· Click submit button
· You will now see a list of current users
13. Create a group
· Select groups
· Click add new group
· Type a name for the group [e.g. Photo Album Editor]
· Make sure the little ‘active’ checkbox is checked/selected
· Click submit button
· You are now back at a list of current groups
· You should be able to see the name you just created.
What are the icons?
· [image: image27.bmp] First icon is green symbol for active.
· [image: image28.bmp] Second icon is a set of keys - for permissions [these are the pages/etc you will allow people to access].
· [image: image29.bmp] Third icon is two little people - for assigning users to this group
· [image: image30.bmp]Fourth icon pencil is to edit whether the group is active.
· [image: image31.bmp] Fifth icon is the bin to delete

Adding a User to a Group 
· Click the name of the new user you just created
· On the right hand side, click to select the little checkbox
· Click submit button.
14. Set the group permissions
· Under users & groups, select group permissions from the menu
· Choose the name of the group you have just created, from the drop down list
· Click on select group
· You will be presented with a long list of ‘actions’ and ‘permissions’ 
· Decide what you want your user to have access to, and click each box on the right hand side to select each item
· If you do not want your user to modify all pages, do not click ‘ modify all pages’
· If you want your user to have access to one page only, do not click any boxes on this page
· Click submit
· You will be back at the group permissions page, and will see the message ‘permissions have been updated’.
15. Adding a user/editor to a page.
· In the top menu, select Content then Pages
· Choose a page and click its link
· When the page opens, you will notice three tabs just below ‘edit content’
· Click the middle one, called options
· At the bottom of this options page, is a field called Owner - usually this is the name of the person who created the page. It could also be super-admin.
· If you click the name, you will see a list of all users - do not select any name.
· Just below this owner’s field, is another long field, called ‘additional editors’
· Select additional editors by holding down your control key plus clicking on the editor name with your mouse.
· Now click the submit button
· At the top of the list of pages you will see, ‘the content was successfully updated’.
To test if it works, logout of the cms, then log back in as the new user - and you should only see the pages you added access to.
16. To remove a user as an additional editor

· Go to Content => Pages select a page and click the options tab.
· Click your new user’s name [from the additional editor list at bottom of page] - just click once to select it
· Hold down control key and click once to remove highlight
· Click the submit button
· At the top of the list of pages you will see, ‘the content was successfully updated’
17. Check Visitor Statistics

Go to Extensions > Statistics to see how many people are looking at your site.

You might also get website visitor statistics from the web-hosting Control Panel of your website hosting service provider.
18. Support by Email

Add contact information for website CMS and/or Server support.[image: image32.bmp][image: image33.bmp][image: image34.bmp][image: image35.bmp][image: image36.bmp][image: image37.bmp][image: image38.bmp][image: image39.bmp][image: image40.bmp][image: image41.bmp]
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